MMANA

Кажется (возможно просто авторский самоидиотизм), что MMANA знают решительно все, кто так или иначе связан с антеннами. Как-то неразумно не знать антенный полигон в компьютере с почти неограниченными возможностями и сервисом, на русском и бесплатный, которому нет равных среди коммерческих программ.
Одна из самых популярных работ - пользователей и русской и английской MMANA насчитывается по много тысяч, причём эти числа постоянно растут.

MMANA, английская и русская

История...

...эта началась давно, в конце 80-х годов. Первые компьютерные анализаторы антенн возвестили закат эры радиолюбительского антенного разгильдяйства. Антенная техника, бывшая смесью действительных знаний, некоей магии, искренних заблуждений и диких слухов ("я тут вчера повесил такую удачную верёвку длиной 43м83,5см, которая прекрасно резонирует во всех диапазонах, включая радиовещательные" - подобные развесистые истории звучали и в эфире, и проникали на страницы печати) становилась подвластной точному расчёту среднего пользователя...
Первые моделировщики были очень просты и ограничивались обсчётом определенных типы антенн. Но с появлением метода моментов (суть которого сводится к разбиению антенны на точки-сегменты и вычислению в каждой точке тока, как собственного, так и наведенного от всех остальных сегментов) ситуация изменилась кардинально. Этот метод не различает типы антенн - все считаются по единой методике.
Первый ELNEC, попавший мне в руки в начале 90-х поразил невиданными возможностями - можно описать произвольную комбинацию проводов и рассчитать её! Возможность эта была настолько ценной, что на недостатки ELNECa глаза закрывались. А было их немало: неудобный DOS-интерфейс, ввод проводов только цифрами координат начала и конца провода (кропотливая и долгая работа, требующая терпения, граничащего с занудством, пространственного воображения, миллиметровой бумаги и калькулятора под рукой - hi), "спотыкабельность" на некоторых типах "трудных" антенн (короткие и параллельные провода, резкие изломы, двухпроводные линии передачи, J-антенна, "толстые" штыри и ряд других) на которых результаты получались далёкими от реальности, малое количество сегментов расчета (120).
Появившийся позднее EZNEC первых версий хотя и решал многие (но не все!) вопросы с точностью вычислений, тем не менее в смысле интерфейса и удобства (вернее - неудобства) пользования был родным братом ELNECа. Что впрочем и неудивительно - оболочки были писаны одним автором W7EL.
Шагом вперед стал NEC4WIN - уже под Windows, он был более удобен. Красивые интерфейсы, возможность вывода в виде трехмерной картинки, возросшее число точек (300), и возможность автоматической оптимизации антенн делали его намного более привлекательным (если конечно не брать во внимание его цену 60...90$). Но эксплуатация выявила все те же, знакомые до зубной боли недостатки - ввод проводов только цифрами, тот же бред в результатах на тех же "трудных" задачах .
Появившийся EZNEC3 под Windows хотя и имел более удобный интерфейс, но W7EL остался верен себе и удобствами пользователя не очень озаботился - все те же длинные ряды цифр в таблице описывающей провода надо было набивать руками. Количество сегментов тоже не поражало воображение - всего 500, маловато для серьёзных антенн. Отсутствие автоматической оптимизации приводило к необходимости настраивать антенну вручную (очень "несложно": найти в десятках цифр в таблице проводов нужные, правильно их изменить, просчитать антенну, посмотреть результат, снова изменить и так множество раз - до полного отвращения).
К началу 2001 года у меня были ELNEC, EZNEC, EZNEC3 и NEC4WIN (антенну приходилось моделировать по очереди во всех программах, и если результаты были относительно похожи друг на друга, то считались правильными) и очень стойкое желание найти хорошую программу по моделированию антенн.
Умные люди говорят, что если чего-то правильно (не сильно, а именно правильно!) захотеть, то это обязательно сбудется... В январе 2001 года Александр RZ1ZR написал, что он нашел программу, которая с успехом моделирует и те "трудные" антенны, на которых бесславно "поломали зубы" и ELNEC и EZNEC и NEC4WIN. Зовут эту программу MMANA, а из недостатков у неё только один - она целиком на японском - hi ( у японцев почему-то принято все лучшее оставлять внутри страны, а на экспорт - то что останется). Автор программы Macoto Mori JE3HHT (MMANA - расшифровывается как Macoto Mori ANtenna Analyzer) широко известен своими программами высококачественными и бесплатными программами MMTTY и MMSSTV.
Скачав программу и "скормив" ей те самые "трудные" задачи, с которыми она легко справилась, я понял - эта вещь мне нужна. Но вот как раз с японским у меня было удивительно плохо. За давностью можно откровенно признаться - мой словарный запас в японском составлял менее десятка слов. Пойти героическим путём RZ1ZR, который "на ощупь" разобрался с основными кнопками и выучил наизусть их расположение у меня не хватило памяти (как выяснилось в дальнейшем сообщений на японском в программе было более семисот!).
На письмо к Maco c просьбой о помощи, и выпуске английской версии MMAMA он ответил, что поскольку он сейчас вовсю делает новую MMSSTV она занимает у него все время и мысли, а заниматься MMANA ему уже неохота - энтузиазм иссяк. Кроме того, Масо сообщил, что у него не так хорошо с английским, чтобы корректно перевести несколько сотен сообщений программы.
Оставалось или отказаться от MMANA (а жалко, моделировала она хорошо!), или изучить японский (как потом выяснилось и это бы не помогла - Maco использовал не очень распространенный диалект японского - hi), или искать третий путь... В переписке Александр RZ1ZR сообщил, что при помощи программы Restorator ему удалось перевести несколько кнопок на английский (по сути Александр и был отцом-основателем английской MMANA) и он отдал свой труд мне на дальнейший перевод. Поскольку с японским было совсем никак, то перевод осуществлялся метод "угадывания", по выполняемым функциям. Такие команды, как "Save", "Save as", "Open" e.t.c. понимались легко. С остальными было хуже, однако так удалось перевести около 200 надписей. В таком сделанном на треть виде программа была в феврале 2001 выложена на web, и сразу нашла своих приверженцев. Огромную помощь оказал Сергей, UA6LGO, который смог машинным переводом (японско-английским) взять большую часть (у Maco был диалект, поэтому всё было нельзя перевести) остающихся надписей. Это было огромное подспорье и дело двинулось вперед, количество переведенных надписей ушло за 500. Это вариант был послан Масо, с тайной целью побудить его доделать оставшееся. Но, Maco не только не стал это делать, а наоборот, прислал мне исходники программы на Borland C++, сказав что он ею больше заниматься не имеет времени, а я если мне очень хочется могу это делать, менять исходники как угодно, не забывая указывать в копирайте кроме себя еще и его. Это дало возможности не только перевода, но и развития программы ( последние версии английской и русской MMANA заметно лучше исходной японской).
Проведенный тогда же опрос показал, что нужен и "русскоговорящий" вариант программы. Переводить с английского было несравненно легче и весной 2001 года на сайте журнала "Радио" была выложена первая (еще с некоторым количеством непереведенных иероглифов) русская версия MMANA.В 6...9\2001 номерах этого журнала была приведено её описание.
В начале лета 2001 на меня вышел Nobuyuki Oba, JA7UDE, известный тем, что он писал английские хелпы к программам Maco MMTTY и MMSTV и предложил совместно (он - хелп, я - софт) довести "до ума" английскую версию MMANA и выложить её на известном сайте MM Hamsoft на котором лежали все программы Масо. Nobuyuki и рассказал, что в оригинале MMANA был не очень распространенный диалект японского, и долго не мог понять как удалось с него столько перевести. Совместная работа, длившаяся около трех недель привела к появлению полностью английской версии MMANA и помещению её на MM Hamsoft .
В дальнейшем регулярно делались обновления английской и русской версий MMANA.
В декабре 2002 года совместно с Александром Шевелёвым DL1PBD, Eike Barthels DM3ML, и Heinz Coenen, DF1EZ была сделана немецкая версия MMANA.

MMANA, где взять, установка, удаление

Скачать самую последнюю версию русской MMANA можно отсюда. Минимальные системные требования:
- 486DX25
- ОЗУ 8 МБ
- разрешение монитора 800х600
- ОС Win95 или выше
Даже при таких скромных условиях MMANA обеспечивает расчет 1024 точек, что достаточно для подавляющего большинства антенн (сравните – большинство платных моделировщиков имеют 300…500 точек максимум). При наличии большего ОЗУ количество точек растет: для 32 Мб - 2048, для 128 Мб - 4096, для 512 Мб - 8192 (!!!).
Для установки, просто разархивируйте файл скачанный zip файл в любую удобную директорию. Программа не создает библиотек *.dll , записей в системном регистре Windows и прочего “мусора”, и полностью готова к работе сразу после распаковки. Вам даже не понадобиться перезагружать компьютер. Более того, она работоспособна даже с дискеты, куда помещается целиком, вместе с большой (>200) библиотекой антенн.
Для удаления (хотя я еще не знаю никого, кому бы MMANA не понравилась и он удалил бы её) просто удалите директорию программы.

Возможности MMANA

Как и во всех моделировщиках метода моментов антенна в MMANA описывается как набор одиночных проводов. Ограничений по их взаимному расположению проводов нет - любая конфигурация проводников будет рассчитана корректно. Сосредоточенные элементы (L, C, R, контура) включаемые в антенну (в любое место) описываются как нагрузки. Описание антенны (в данном случае это три элемента очень странной японской антенны - Hentenna) выглядит как показано ниже (это закладка "Геометрия"):
4-1-1.gif (17772 bytes)
Вот эту самую, громоздкую табличку Wire другие моделировщики предлагают набивать вручную. Сущая ерунда , в данном случае 21 провод, по 7 координат (по три на начало и конец + радиус ) на каждый, итого 140 с чем-то безошибочных цифр и описание антенны готово. Нравится? Мне совершенно нет, а вот производителям коммерческого софта - очень, по крайней мере они только так и предлагают создавать описания антенн. В MMANA тоже можно так, но есть способ лучше и понятнее - просто рисовать мышкой (о нём ниже), а пока посмотрим, что за антенна такая описана, и перейдем для этого в закладку "Вид", которая выглядит так:
4-1-2.gif (18892 bytes)
Видно три элемента странновато вытянутых вверх сложных рамок, в правом нижнем углу описание выделенного (утолщенная черная линия) провода. Вверху справа при создании скриншота я "уложил" всплывающее меню (в норме его нет на экране), в котором есть множество полезных опций. Обращу внимание только на одну из них "Установки комбинированного провода - она позволяет устанавливать состоящие из нескольких, разных диаметров провода. Полезно при расчете элементов, составленных из труб разного диаметра, например "волновых каналов". Еще на этом скриншоте показано распределение токов по антенне (красным и синим) - вещь очень нужная для анализа и понимания. Впрочем тут я немного сжульничал - если просто Вы перейдете из "Геометрии" в "Вид", то распределения токов не увидите, потому что сначала надо сделать расчёт антенны в закладке "Вычисления", скриншот которой (после вычислений уже) вот:
4-1-3.gif (15010 bytes)
Тут задан тип земли, высота антенны (очень удобно - можно двигать антенну вверх-вниз), и в таблице даны результаты вычислений со всеми параметрами антенны. Не очень информативная форма представлений информации? Согласен, и вот поэтому перейдем в следующую закладку "Диаграммы направленности":
4-1-4.gif (17450 bytes)
Тут уже гораздо все красивее и нагляднее, не правда ли? А можно еще посмотреть графики частотных зависимостей всех основных параметров антенны:
4-1-7.gif (8695 bytes)
4-1-8.gif (9465 bytes)
4-1-9.gif (9137 bytes)
4-1-10.gif (16578 bytes)
Обычно после получения и анализа результатов возникает желание что-нибудь в антенне поменять. Но лезть для этого в таблицу проводов с её колоннами цифр... бр-р-р-р, не приведи Господи. Но к счастью такой ерундой заниматься не придется, откроем окно "Правка провода" и можем там делать все что захотим: добавлять-удалять провода, передвигать существующие и рисовать новые. Вот пример скриншота в процессе перетаскивания мышкой на новое место существующего провода:
4-1-5.gif (16143 bytes)
Перетаскиваемый провод выделен красным. Его текущее положение в процессе движения - тонкой линией (в данном примере - наклонной, на её конце виден курсор мыши). Рисовать так объёмные антенны - одно удовольствие - попробуйте! Тоже самое (и даже больше - см. всплывающее меню на следующем скриншоте) можно делать и на плоских видах:
4-1-6.gif (26616 bytes)
Кроме "Правки провода" есть еще и "Правка элемента", где можно легко и удобно вводить и править многоэлементные антенны. Создание файла модели например 10 элементной Яги (или квадрата, дельты - словом элемента любой формы) занимает несколько минут все вводится в очевидной, интуитивно понятной форме - размер элемента (или его периметр для рамочных элементов) и расстояние между элементами.
Есть удобная возможность автоматической оптимизации по нескольким разным критериям (Усиление, КСВ, минимум реактивности, минимум вертикального угла излучения, оптимум для согласования) изменяя более чем 90 параметров антенны. Антенна автоматически настраивается на по заданным Вами критериям.
Можно чрезвычайно просто создавать стеки, используя существующую антенну (любую!) как базовый элемент - для этого в специальном меню достаточно указать количество этажей по горизонтали и вертикали и расстояние между ними.
В общем, в деле заботы о человеке и удобстве создания и правки самых разных, в том числе очень сложных антенн MMANA даже неудобно сравнивать со всякими ELNEC, EZNEC, NEC4WIN - небо и земля. Не преувеличиваю, попробуйте и сами в этом убедитесь.
В MMANA можно сравнивать разные антенны. На скриншоте показаны наложенные друг на друга 3 диаграммы направленности: упомянутой Нentennы на высоте 1 и 4 м (коричневая и зелёная соответственно) над землёй, и обычного тройного квадрата на высоте 4 м (чёрная).
4-1-11.gif (20349 bytes)
Вот это и есть совершенно объективное сравнение, и не надо ничьих "авторитетных" мнений спрашивать.
Также можно рассчитывать катушки, контура, СУ на LС элементах, СУ на отрезках длинных линий (несколько разных видов), индуктивности и емкости, выполненные из коаксиального кабеля. Там много возможностей, приведу только одну - автоматического расчёта трансформации импеданса длинными линиями. Просто введите длину линии и импеданс нагрузки - и сразу получите ответ.
4-1-12.gif (6834 bytes)
При всей внешней простоте это окошко заменяет многоэтажные формулы и сложные диаграммы. И таких полезных и удобных вещей в MMANA множество.

Я упомянул в этой статье только основные функции MMANA, общее число их очень велико, и даже простое перечисление займет много места. Но все они выполнены легко и понятно в управлении. Конечно для освоения MMANA (как и любой другой программы) потребуется время и усилия. Не считайте их потерянными - наоборот, они многократно окупятся при изготовлении и настройке реальных антенн.

После создания русской MMANA я удалил с со своего винчестера ELNEC и NEC4WIN (что и Вам советую они на той же математике MININEC, что и MMANA но несравненно более корявы, неудобны и ограничены в возможностях), и оставил лишь EZNEC, и то лишь потому, что он использует другую математику (NEC-2), и в некоторых особых случаях (например горизонтальные антенны, низко расположенные над реальной землей <0,2l) даёт более точные результаты по входному импедансу.

Скачать русскую MMANA можно ( не можно, а нужно! :-)) с сайта журнала "Радио", куда я выкладываю новые версии программы. Некоторые мои ответы на вопросы пользователей программы, и их отзывы можно прочесть в "Переписке по MMANA", а дополнительные (не входящие в стандартную библиотеку MMANA) файлы моделей любопытных антенн найти в моей библиотеке файлов MMANA.

Полное описание возможностей MMANA было дано в вышедшей из печати в конце апреля 2002 года книжке "Компьютерное моделирование антенн. Всё о программе MMANA". Книга была написана и выходит в свет по инициативе и благодаря усилиям Бориса Степанова, RU3AX, за что ему отдельное и большое спасибо.

В настоящее время готовится к выходу в свет второе издание этой книги - расширенное и дополненное.

На первую страницу